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Authorize.net Payment Gateway error when performing a test transaction in the gateway administration module

Views: 672
Posted: 06 Sep, 2008
by: Admin A.
Updated: 18 Feb, 2009
by: Admin A.

SYMPTOMS

When using the Authorize.net test gateway functionality in the "Payment Gateway - Authorize.net" module you receive a processing error even though you are sure your credentials are active and valid.

Authoirze.net AIM Gateway Test error

CAUSE

Authorize.net has test and live servers that process gateway transactions, Authorize.net for last several years expected test requests to be passed to their test server for processing. This was by default the server our implementation sent all test requests to, this has now changed and now live credentials (not developer credentials) must be sent to the live server even for test requests.

RESOLUTION

  1. Open the following file in your default installation globals\adminpro_aim.cfm
  2. Scroll to approx line 82 in the code for this file or until you see code similar to below
    Old AIm Code

    OR if you have an older build you may see code like below
    AIm Old Code Older build

  3. Once you locate the cfparam tags that specify the AuthServer default value delete all these lines and add in their place the following 1 line of code
    AIM New code

  4. Save the file and upload to your server and perform a test transaction again to receive a valid response.
  5. A successful test request should look similar to the result screen shown below
    AIm Successful test

NOTE:

If you receive a message such as the one below, this is not a module or application error this simply indicates that Authorize.net or your merchant (or both) have not yet setup your account to accept certain cards (such as American Express or Discover, by default usually only Visa/MasterCard are established on a new Authorize.net account).

AIM Error - Card Not Supported

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